Jump to content


Photo

JPLAY FEMTO NAS Issues

NAS bugs

  • Please log in to reply
97 replies to this topic

#81 satbaba

satbaba

    Die Hard

  • Members
  • PipPipPip
  • 115 posts

Posted 29 March 2019 - 04:32 AM

server 2019 standart core

#82 DC

DC

    Die Hard

  • Members
  • PipPipPip
  • 375 posts

Posted 29 March 2019 - 09:20 AM

Ok, I confirm it works with Windows Server 2016 Core but I haven't tried with 2019.. I'm sorry.


  • satbaba likes this

#83 DC

DC

    Die Hard

  • Members
  • PipPipPip
  • 375 posts

Posted 29 March 2019 - 03:10 PM

Apparently as I wrote in this post , PsExec64.exe needs services such as "Lanmanserver" and "lmhosts" to be able to run.

 

Are they still present in Windows Server 2019 Core?

Is AO 3.0 beta enabled on your Windows Server 2019 Core?

 

If AO 3.0 is enabled perhaps read this other post I wrote few months ago. It could help you.

 

http://jplay.eu/foru...issues/?p=46345



#84 satbaba

satbaba

    Die Hard

  • Members
  • PipPipPip
  • 115 posts

Posted 31 March 2019 - 06:18 AM

 I can't use NAS,  with windows server2019 core standard
please help


#85 Marcin_gps

Marcin_gps

    JPLAY team

  • Administrators
  • 3,392 posts

Posted 31 March 2019 - 07:08 PM

Please try this method instead of psexec described in the manual. Open Command Prompt (CMD.exe) as Administrator and run this command: 

 

    schtasks /Create /RU SYSTEM /SC ONSTART /RL HIGHEST /DELAY 0000:10 /TN JPLAY_NAS_MAP /TR "net use Z: \\<NAS_IPaddr>\<Dir> /user:WORKGROUP\<username> <password> /persistent:no"

 

 

If you need the same NAS to be accessibe  by other apps (e.g. Roon), it must be mapped again under a different letter using Administrator account:

    schtasks /Create /SC ONLOGON /RL HIGHEST /DELAY 0000:10 /TN ROON_NAS_MAP /TR "net use Y: \\<NAS_IPaddr>\<Dir> /user:WORKGROUP\<username> <password> /persistent:no"

 

    To start the tasks simply run these commands:

    schtasks /Run /tn JPLAY_NAS_MAP

    schtasks /Run /tn ROON_NAS_MAP

 

Note: If you use AO then you need to Enable Network access

Under system account, the NAS cannot be seen by any other app  except for JPLAY FEMTO - it appears with red X. Disconnected

 

 

Regards, 

Marcin


  • p_hsieh likes this

JPLAY & JCAT Founder


JPLAY FEMTO: a complete network music software player for the most demanding audiophile.

Want to squeeze more from your PC-audio? Hear the difference with JCAT

#86 satbaba

satbaba

    Die Hard

  • Members
  • PipPipPip
  • 115 posts

Posted 01 April 2019 - 10:11 AM

Thanks, I will try



#87 satbaba

satbaba

    Die Hard

  • Members
  • PipPipPip
  • 115 posts

Posted 18 April 2019 - 11:22 AM

I tried , works fine

thank you very much, Marcin_gps  :)  



#88 Marcin_gps

Marcin_gps

    JPLAY team

  • Administrators
  • 3,392 posts

Posted 18 April 2019 - 12:25 PM

I tried , works fine

thank you very much, Marcin_gps  :)  

Excellent! :)


  • satbaba likes this

JPLAY & JCAT Founder


JPLAY FEMTO: a complete network music software player for the most demanding audiophile.

Want to squeeze more from your PC-audio? Hear the difference with JCAT

#89 Cloclo

Cloclo

    Beginner

  • Members
  • 12 posts

Posted 30 April 2019 - 05:50 PM

Hi Marcin,

I have been trying for some time to add an external HDD to my Control PC. I reinstalled Jplay and added the HDD drive\folder (H:\Music2) to the Libary, but when I try to access its music content throught BubbleUPnP's library, I get the same error reported in this thread for unmapped NAS drives:

Browse error

Reason: Attempt to invoke virtual method 'int java.lang.String.length()' on null object reference

 

I tried all the PSexec64 and schtaks remedies suggested in this thread, but cannot solve the issue. The external HDD remains unaccesible.  

Any help would be greatly appreciated - Many thanks!



#90 Cloclo

Cloclo

    Beginner

  • Members
  • 12 posts

Posted 30 April 2019 - 11:25 PM

PS: having inverted the order with which I attempted to load the 2 driver ("H:\MyMusic, C:\MyMusic" instead of "C:\..,H:\..") on Jplay's library upon reinstalling once again the program, I discovered that the issue is not with the external vs. internal driver, but rather with the fact that only the first drivers becomes accessible. Now the content of H:\ can be played, whereas attempting to browse C:\ giver the error:

Browse error

Reason: Attempt to invoke virtual method 'int java.lang.String.length()' on null object reference

 

...the plot thickens



#91 Miksi

Miksi

    Beginner

  • Members
  • 7 posts

Posted 01 May 2019 - 07:56 AM

Hello, I can see now library from my other computer in Bubble but can't play anything on Femto renderer. It just won't start playing. It plays on android. My computers are on Win10Pro



#92 Miksi

Miksi

    Beginner

  • Members
  • 7 posts

Posted 01 May 2019 - 03:30 PM

My mistake, it doesn't play on android from femto server, it was a classic windows server. Nothing plays from femto server or to femto renderer...

From other servers plays on my Samsung tv's, archpile on raspberry pi ....

Tried also Fidata app on android the same thing happens, I can see femtoserver library and all album icons and files but it can't play anything from femtoserver or to femtorenderer.

It's one PC configuration on NUC i7 from 2015, it just has mapped music folder from my other computer on network. Tried before playing from foobar directly on my usb dac (XMOS) trough jplay and it works but that doesn't involve femto renderer.

Tried several times during past few months when I had the time but only recently managed to enable NAS as network drive. When I bought licence last year, I've had success playing Tidal through Bubble on femto renderer but that doesn't work anymore also.



#93 Miksi

Miksi

    Beginner

  • Members
  • 7 posts

Posted 01 May 2019 - 03:56 PM

Solved. For some reason femto renderer doesn't like to work with xmos receiver in Asio mode. Kernel streaming works.


  • Marcin_gps likes this

#94 Marcin_gps

Marcin_gps

    JPLAY team

  • Administrators
  • 3,392 posts

Posted 02 May 2019 - 08:41 AM

PS: having inverted the order with which I attempted to load the 2 driver ("H:\MyMusic, C:\MyMusic" instead of "C:\..,H:\..") on Jplay's library upon reinstalling once again the program, I discovered that the issue is not with the external vs. internal driver, but rather with the fact that only the first drivers becomes accessible. Now the content of H:\ can be played, whereas attempting to browse C:\ giver the error:

Browse error

Reason: Attempt to invoke virtual method 'int java.lang.String.length()' on null object reference

 

...the plot thickens

Are you using the latest 7d build of JPLAY FEMTO? 


JPLAY & JCAT Founder


JPLAY FEMTO: a complete network music software player for the most demanding audiophile.

Want to squeeze more from your PC-audio? Hear the difference with JCAT

#95 Cloclo

Cloclo

    Beginner

  • Members
  • 12 posts

Posted 02 May 2019 - 11:33 PM

Hi Marcin.
Yes I am. 7d
Thanks

#96 Marcin_gps

Marcin_gps

    JPLAY team

  • Administrators
  • 3,392 posts

Posted 03 May 2019 - 11:09 AM

Hi Marcin.
Yes I am. 7d
Thanks

OK, thanks

Please try reinstalling JPLAY and instead of folders, please specify drive letters alone: "C:, H:,'


JPLAY & JCAT Founder


JPLAY FEMTO: a complete network music software player for the most demanding audiophile.

Want to squeeze more from your PC-audio? Hear the difference with JCAT

#97 Cloclo

Cloclo

    Beginner

  • Members
  • 12 posts

Posted 08 May 2019 - 10:03 PM

Hi Marcin. Thank you for the suggestion. Unfortunately, the result is unchanged. Only the first drive in the sequence "C:, H:" or "H:, C:" is accessible. For some reason I seem limited to a single path or drive for the library. BR

#98 Marcin_gps

Marcin_gps

    JPLAY team

  • Administrators
  • 3,392 posts

Posted 09 May 2019 - 09:14 AM

ok, please contact us via email on support for a debug build

 
 
Regards, 
Marcin

JPLAY & JCAT Founder


JPLAY FEMTO: a complete network music software player for the most demanding audiophile.

Want to squeeze more from your PC-audio? Hear the difference with JCAT




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users